Pump hose won't stay in.

Problems with your kayak? Tracking to one side over the other? Taking on water? Losing Air? Post your questions, suggestions and answers here regarding issues with the kayaks.

Moderators: JCOOLEY, rsimpson

Post Reply
fkuxhouse
Posts: 1
Joined: Mon Mar 17, 2008 7:23 am

Pump hose won't stay in.

Post by fkuxhouse » Mon Mar 24, 2008 7:05 am

Hello. I just bought the AE AF and took it out for the first time. I had difficulty inflating it as the pump hose wouldn't stay in place when trying to inflate the 2 main compartments. Am I missing something? I had to hold it in place with one hand and try pumping with the other. It fit fine on the other valves. The pump is the Advanced elements hand pump that came with it. Also, how do you know if it's properly inflated without being over inflated? I'm not sure if I inflated it properly as it seemed a bit sluggish when paddling. Any help/tips would be greatly appreciated. Oh by the way, the maintenance kit wasn't in the box either. Anyone else have this problem? Thanks.

JCOOLEY
Site Admin
Posts: 983
Joined: Tue Feb 20, 2007 2:46 pm
Location: Benicia, CA

Post by JCOOLEY » Mon Mar 24, 2008 9:01 am

The repair kit is located in the mesh pocket on the back of the seat. It is in a little black pouch.
Sometimes the adaptor on the pump just won't fit snug enough. A very easy fix is to take masking tape and wrap it around the pump attachment. This will increase the diameter and because it is masking tape, it has a little grip on it as well.
Once you are done inflating the kayak and you pick it up from either end, it should not fold, bend or taco in the middle. If it does this, then you do not have enough air in the kayak. It is a little difficult to overinflate the two main chambers. It is mostly the floor that you have to look out for.

Jeremy
8)

Post Reply